1
Vote

Installation issue

description

Hi,
 
When I try to install the web part using
C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN>stsa
dm.exe -force -globalinstall -o addwppack -f SPVisibilityFilter_Deployment.cab
 
I get
Object reference not set to an instance of an object.
SPVisibilityFilter_Deployment.cab: The Web Part deployment failed.
 
Thanks,
Nagu

comments

JoeD wrote Sep 6, 2009 at 2:00 AM

Nagu,

Have you been able to install any web parts using stsadm? My research on this error message indicates it is permissions related (for example, see http://www.ofonesandzeros.com/2009/08/24/object-reference-not-set-to-an-instance-of-an-object-executing-stsadm-commands/).

Are you logged in as an administrator?

Shiv1583 wrote Mar 27, 2012 at 2:03 PM

Hi, I am trying to use the webpart however, i am getting this error:
'Microsoft.SharePoint.Security.SharePointPermission, Microsoft.SharePoint.Security, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' failed.
Please help.

JoeD wrote Mar 27, 2012 at 7:47 PM

Are you logged in as a Sharepoint farm administrator/domain administrator?

Did you do the stsadm command exactly as above?

Shiv1583 wrote Mar 28, 2012 at 5:11 AM

Hi JoeD,
We are actually 3 administrators on the server, after going through the installation steps again. I found that the solution was not deployed to the GAC (through Central Admin) by the previous administrator.

Thank you for the quick response though, i appreciate it.

wrote Feb 14, 2013 at 2:19 AM